Составить программу для паскальабс.нет. количество чисел не кратных пяти в указанном диапазоне

Титанэжжжжж Титанэжжжжж    3   28.06.2019 11:50    3

Ответы
ЯнаВасиленко ЯнаВасиленко  22.07.2020 18:23
Program vasha_zadacha_1;
var a,b,c:integer ; 
begin 
c:=0; 
writeln('введите промежуток от'); 
readln(a); 
writeln('до'); 
readln(b); 
if a>b then  
for b:=b to a do begin 
if (b mod 5<>0) then c:=c+1;   
end; 
for a:=a to b do begin   
if (a mod 5<>0) then c:=c+1; 
 end; 
writeln('колличество чисел не кратных пяти в этом диапазоне ', c); 
end.
ПОКАЗАТЬ ОТВЕТЫ
мася277 мася277  22.07.2020 18:23
Var i, a, b, count, crat:integer;
begin
readln(a, b);
for i:=a to b do
begin
crat:=i mod 5;
if crat <> 0 then
begin
count:=count+1
end;
end;
writeln('Количество не кратных = ', count);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика