Составить программу для pascalabc, которая выводит слово, введённое с клавиатуры, с буквами в обратном порядке и сохраняет результат в оперативную память

НагецБлайзер НагецБлайзер    1   26.05.2019 10:20    5

Ответы
vikaberg vikaberg  22.06.2020 20:21
Вот программа, которая выводит слово в обратном порядке. Об оперативной памяти может не понял, но по-моему оно и так туда сохраняется, по крайней мере во время работы программы:

Program Task;
Var s, r: String;
i: Integer;
Begin
WriteLn('Введите слово:');
ReadLn(s);
SetLength(r, Length(s));
For i := 1 To Length(s) Do
r[i] := s[Length(s) - i + 1];
WriteLn('Результат:');
WriteLn(r);
ReadLn;
End.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика