Составить программу для нахождения для данного натурального числа сумму его чётных делителей

анна2259 анна2259    1   17.05.2019 22:00    4

Ответы
kamilskylinep0a6rx kamilskylinep0a6rx  11.06.2020 04:06

var

a,i,res: integer;

begin

writeln('Введите число');

readln(a);

for i:=1 to a do

begin

if i mod 2=0 then

begin

if a mod i=0 then res:=res+i;

end;

end;

writeln(res);

end.

Объяснение:

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика