Составить блок-схему и написать программу для проверки того, что в сумма цифр некоторого числа равна 10

Atiko88 Atiko88    3   20.09.2019 21:20    2

Ответы
nastya09042 nastya09042  08.10.2020 05:31
Замечание: предполагается, что вводятся натуральные числа.
Блок-схема - в прилагаемом файле.
var a,s:integer;
begin
readln(a);
s:=0;
while a>0 do
 begin
 s:=s+a mod 10;
 a:=a div 10;
 end;
writeln('s = ',s);
if s=10 then writeln('s = 10')
else writeln('s <> 10');
end.

Пример:
527
s = 14
s <> 10
Составить блок-схему и написать программу для проверки того, что в сумма цифр некоторого числа равна
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика