Составить блок-схему и написать программу для определения суммы нечетных цифр некоторого числа n. указание: для того, чтобы взять одну цифру из заданного числа n необходимо использовать операцию n mod 10.

Мейвис00 Мейвис00    2   20.09.2019 21:30    5

Ответы
svyaznoi230113 svyaznoi230113  08.10.2020 05:41
Замечание: считается, что число N - натуральное.
Блок-схема - в прилагаемом файле.
var a,s:integer;
begin
readln(a);
s:=0;
while a>0 do
 begin
 if a mod 2=1 then s:=s+a mod 10;
 a:=a div 10;
 end;
writeln('s = ',s);
end.

Пример:
1234567
s = 16
Составить блок-схему и написать программу для определения суммы нечетных цифр некоторого числа n. ук
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика