Составить алгоритмы и программы длясоставить алгоритмы и программы для заполнения : массива а (30) по формуле a(i) = 10*i + 2*i2. найти среднее арифметическое элементов < 50. распечатать массив в строку. составьте программу

Эрайз Эрайз    1   28.05.2019 05:30    5

Ответы
Pузик Pузик  25.06.2020 15:42
Если я правильно понял условие, то код выглядит так.
uses crt;
var i,ans,sum:integer;
a:array[1..30] of integer;
begin
sum:=0;
ans:=0;
for i:=1 to 30 do
begin
a[i]:=10*i+2*sqr(i);
if a[i]<50 then
ans:=ans+1;
sum:=sum+a[i];
end;
writeln(sum/ans);
for i:=1 to 30 do
write(a[i],' ');
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика