Сна паскаль!
составить программу для решения : дано натуральное число n. вычислить , определяемое как произведение честных чисел от 2 до n, если n честно, либо как произведение нечетных чисел от 1 до n, если n нечетно.

kamilla198 kamilla198    2   16.09.2019 15:55    4

Ответы
JHope23 JHope23  07.10.2020 20:02

program raf105;

var

 n,pro: integer;

begin

 write('n = ');

 readln(n);

 pro:= n;

 while n-2 > 0 do

 begin

   pro:= pro * (n-2);

   n:= n - 2;

 end;

 writeln('Вывод: ',pro);

end.

PascalABC
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика