Сложные условия ветвления ! напишите программу, которая получает три числа и выводит количество одинаковых чисел в этой цепочке. пример: введите три числа: 5 5 5 все числа одинаковые. пример: введите три числа: 5 7 5 два числа одинаковые. пример: введите три числа: 5 7 8 нет одинаковых чисел.
// Внимание! Если программа не работает, обновите версию!
begin
case ReadSeqInteger('Введите три целых числа:',3).Distinct.Count of
3:Writeln('Нет одинаковых чисел');
2:Writeln('Два числа одинаковые');
else Writeln('Все числа одинаковые')
end
end.
Примеры
Введите три целых числа: 5 5 5
Все числа одинаковые
Введите три целых числа: 5 7 5
Два числа одинаковые
Введите три целых числа: 5 7 8
Нет одинаковых чисел