Склавиатуры вводится трехзначное число. составьте программу выводящую сумму его чисел.

nizyulkoelena nizyulkoelena    3   08.03.2019 17:50    4

Ответы
58310 58310  24.05.2020 07:39

var
  a, s: integer; // целочисленный тип данных

begin
writeln('Введите число:');
  readln(a); // вводим число (можно больше трех знаков)
  while a <> 0 do  // пока остались цифры в числе выполнять...
  begin
    s := s + (a mod 10); // Отбираем последнюю цифру числа и прибавляем к сумме
    a := a div 10; // Стираем последнюю цифру числа
  end;
  writeln('Сумма цифр = ', s) // выводим результат
end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика