Сделайте программу и блок-схему к : даны два действительных положительных числа x и y. тригонометрические действия над числами пронумерованы (1 - sin, 2 - cos, 3 - tg, 4 - ctg). составить программу, которая по введенному номеру n выполняет то или иное действие над числами x и y.

jasmin301 jasmin301    2   09.06.2019 05:00    2

Ответы
DoctorVatson1 DoctorVatson1  08.07.2020 01:45
Var
  x, y, rx, ry: real;
  n: integer;
  s: string;

begin
  writeln('Введите два положительных числа');
  readln(x, y);
  writeln('Введите код операции от 1 до 4');
  readln(n);
  case n of
    1: begin rx := sin(x); ry := sin(y); s := 'sinX' end;
    2: begin rx := cos(x); ry := cos(y); s := 'cosX' end;
    3: begin rx := tan(x); ry := tan(y); s := 'tgX' end;
    4: begin rx := 1 / tan(x); ry := 1 / tan(y); s := 'ctgX' end;
  else begin rx := 0; ry := 0; s := '???' end
  end;
  writeln('Результаты для ', s, ': ', rx, ', ', ry)
end.

Тестовое решение:

Введите два положительных числа
4 5
Введите код операции от 1 до 4
2
Результаты для cosX: -0.653643620863612, 0.283662185463226

Сделайте программу и блок-схему к : даны два действительных положительных числа x и y. тригонометрич
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика