C/c++.

найдите наименьший четный элемент массива. если такого нет, то выведите первый элемент.

dnmsmd dnmsmd    2   07.08.2019 17:24    26

Ответы
vektar1234 vektar1234  04.10.2020 03:22

#include <iostream>

using namespace std;

int main() {

int n, k=0;

cin>>n;

int arr[n];

for (int i=0; i<n; ++i) {cin>>arr[i]; if (arr[i]%2==0&&(arr[i]<arr[k]||arr[k]%2==1)) k=i;}

cout<<arr[k];

return 0;

}

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика