Сделайте Написать программу нахождения суммы и среднего арифметического значения элементов целочисленного массива размерностью n. С одномерного массива.

n равен количеству букв в вашем имени (например, Лев - размерность 3, или Вероника - размерность 8)

*размерность - количество элементов массива

maksimmolotov2 maksimmolotov2    3   05.12.2020 02:17    2

Ответы
yuliyakoshka0 yuliyakoshka0  04.01.2021 02:21

#include <iostream>

using namespace std;

int main() {

srand(time(NULL));

string s;

int n;

float sum=0;

cin>> s;

n= s.length();

int a[n];

for(int i=0;i<n; i++)

{a[i]= random()%10;

sum+=a[i];

cout<<a[i]<<" ";

}

cout<<endl<<"Сумма всех элементов = "<<sum;

float sum1= sum/n;

cout<<endl<<"Среднее арифметическое = "<<sum1;

return 0;

}

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика

Популярные вопросы