С++ Составить программу нахождения значения функции, исчисляется в зависимости от значения аргумента.

Непонятно куда и во что его пихать. Это даже не функция, а непонятно что.


С++ Составить программу нахождения значения функции, исчисляется в зависимости от значения аргумента

Vika47696 Vika47696    1   02.10.2021 03:02    6

Ответы
OlgaNazarenko123 OlgaNazarenko123  02.10.2021 06:00

#include <iostream>

#include <cmath>

int main() {

 double x;

 std::cin >> x;

 if (1.0 < x <= 12.5) {

     std::cout << 3 * pow(x, -3) << std::endl;

 } else if (x > 12.5) {

     std::cout << 13.44 << std::endl;

 } else if (-15.4 <= x <= 1.0) {

     std::cout << atan(abs(x + 1)) << std::endl;

 } else {

     std::cout << 1 << std::endl;

 }

 return 0;

}

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика