С. напишите программу подсчёта суммы всех отрицательных элементов заданного целочисленного массива размером 30 элементов. если отрицательных элементов нет, то сообщить об этом) p.s. в паскале

ClarisVerbis ClarisVerbis    1   19.06.2019 07:40    4

Ответы
inan228 inan228  15.07.2020 17:11
Var
  n, i, s, k:integer;
  a:array [1..30] of integer;
begin
  writeln('Vvedite massiv');
  for i:=1 to 30 do
  readln(a[i]);
  writeln('Massiv');
  for i:=1 to 30 do
  write(a[i],' ');
  writeln();
  k:=0; s:=0;
  for i:=1 to 30 do
  if a[i]<0 then
  begin
  s:=a[i]+s;
  k:=1;
  end;
  if k=1 then
  writeln('Summa otricatelnih elementov: ',s)
  else
  writeln('Otricatelnih elementov net');
  readln();   
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика