С++ напишите программу, которая выводит номера элементов массива, равных заданному значению x . входные данные первая строка содержит размер массива n . во второй строке через пробел n чисел – элементы массива. в третьей строке записано число x . гарантируется, что 0 < n ≤ 10000 . выходные данные программа должна вывести в одной строке номера элементов массива, равных x , разделив их пробелами. предполагается, что нумерация начинается с единицы. если таких элементов нет, нужно вывести число -1.

девочка245 девочка245    2   23.07.2019 01:30    16

Ответы
alekseyovsyann alekseyovsyann  03.10.2020 11:18
#include<iostream>#include<stdlib.h>using namespace std;int main(){ int n,i,j=0,k; cin>>n;  int a[n]; for(i=0;i<n;i++) { cin>>a[i]; } int X; cin>>X; int W[n]; for(i=0;i<n;i++) { if(a[i]==X) { W[j]=i; j++; }   } for(i=0;i<j;i++) cout<<W[i]<<" ";}
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика