С

Напишем программу, которая имитирует процесс ввода пароля:
если пароль введен верно, должны выводиться сообщение "Successful login", если же пароль был введен неправильно, то должно выводиться сообщение "Wrong password". Если же пароль был введен неправильно 3 раза, то процесс ввода должен прерываться и должно выводиться сообщение "Access denied".

Начинаться программа должна с вывода сообщения "Enter correct password", после чего должно предлагаться ввести правильный пароль, после чего уже должны вводиться попытки ввода этого пароля.

Формат входных данных

Исходная строка p - правильный пароль.

Неопределенное количество строк возможных паролей.

Формат выходных данных

Сообщения в виде, описанном в условии.

входные данные

qwerty123

Qwerty12

QwErTy123

qwerty123

QWERTY

qwertty

QwERtyY

1234

выходные данные

Enter correct password

Wrong password

Wrong password

Successful login

Enter correct password

Wrong password

Wrong password

Wrong password

Access denied

StanleyPines618 StanleyPines618    2   19.01.2021 18:27    44

Ответы
ка566 ка566  18.02.2021 18:27

Объяснение:

#include <iostream>

#include <string>

using namespace std;

int main()

{

  string p = "qwerty123", p2;

  int k=0;

  cout << "Enter correct password"<<endl;

  while(p2!=p || k<3){

      cin >> p2;

      if(p == p2) { cout << "Successful login" << endl; k=4;}

      if(p != p2) {

         cout <<"Wrong password" << endl;

         k++;}

      if(k==3) { cout <<"Access denied" << endl;}

  }

   

   return 0;

}

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика