tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Составьте программу
Составьте программу для вычисления площади четырёхугольника с координатами вершин (x1, , , , y4).площадь четырёхугольника вычислите как сумму площадей двух треугольников.
UzZzeR
3 29.05.2019 20:30
2
Ответы
КсенияКения2006
29.06.2020 07:20
TYPE
TPoint = Record x, y: Real; End;
VAR
a, b, c, d: TPoint;
Function Pl(a, b, c: TPoint): Real;
Var v1, v2: TPoint;
Begin
v1.x := a.x - b.x; v1.y := a.y - b.y;
v2.x := a.x - c.x; v2.y := a.y - c.y;
Pl := Abs(v1.x * v2.y - v1.y * v2.x) / 2;
End;
BEGIN
Read(a.x, a.y, b.x, b.y);
Read(c.x, c.y, d.x, d.y);
Write(Pl(a, b, c)+Pl(a, c, d));
END.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
slusarenkolena
19.06.2020 01:56
Выведены ФИО всех студентов. Что это? 1 выборка 2 проекция 3 смешанный запрос 4 необходимы дополнительные данные...
Знания
19.06.2020 02:01
Дана строка из N символов. Группы символов, разделенные пробелами (одним или несколькими) и не содержащиепробелов внутри себя, будем называть словами.Преобразовать данную...
svetlanaka123
12.02.2021 11:34
Используя команду повернуть в направлении ,напишите программу,рисующий орнамент ...
David2209
12.02.2021 11:31
Написать этому коду блок-схему #include using namespace std; bool check(string &s){ for(auto &i : s) if(!(i = 0 && i = 9 )) return false; return true;...
Belka1712
12.02.2021 11:29
Как называется один шаг циклического процесса а) команда циклаб) тело циклав) итерацияг) инкремент...
buster43
12.02.2021 11:26
1. Дана длина ребра куба. Найти объем куба и площадь его боковой поверхности. 2. Три сопротивления R1, R2, R3 соединены параллельно. Найти сопротивление соединения. 3....
MisterPOR
12.02.2021 11:23
Нарисуйте переключательные схемы (во вложении задача) ...
Ангелок1105
12.02.2021 11:22
Друзья, доброго времени суток. Подскажите чем связаны предметы информатика и черчения. Просто примеры для презентации...
Uliana44441
12.02.2021 11:22
Скласти програму, яка замінює мінімальний елемент списку на протилежний.Вхідні дані 10 5 -7 8 9 3(В python) ...
Karton2288
12.02.2021 11:21
привести примеры чем связана информатика и черчение...
Популярные вопросы
1.Площа основи призми дорівнює 6 см кв., а її об єм - 54 см куб.....
3
Складіть 5 речень зі словами :Ісh,helfe,leiht,Gib,eine,Klaus,meiner,mir,Eltern,eine,mir,der,Lederjacke,Freundin,Mutter,kaufst,seiner,du,Freundin,Kassette,doch,Vater,in...
3
Эссе сусыз тиршилик жок 100 слов ...
3
А можно решение к данной задаче ?...
3
2 Label the parts of the body 1.h 2.t 3.l 4.h 1b 2w 3f 4c...
3
построить график функции.y=-2(x+3)^2-1...
1
Прочитайте данный отрывок и выделите детали, характеризующие Простакову...
2
Составьте синквейн к существительному слово...
1
At this note, try to guess what is it and what information have you...
1
В каком эпизоде фильма «Алые паруса» наиболее ярко проявился характер...
1
TPoint = Record x, y: Real; End;
VAR
a, b, c, d: TPoint;
Function Pl(a, b, c: TPoint): Real;
Var v1, v2: TPoint;
Begin
v1.x := a.x - b.x; v1.y := a.y - b.y;
v2.x := a.x - c.x; v2.y := a.y - c.y;
Pl := Abs(v1.x * v2.y - v1.y * v2.x) / 2;
End;
BEGIN
Read(a.x, a.y, b.x, b.y);
Read(c.x, c.y, d.x, d.y);
Write(Pl(a, b, c)+Pl(a, c, d));
END.