tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
С++ написать программу, которая
С++ написать программу, которая по введённому пользователем названию месяца будет выдавать количество дней в этом месяце.
emerenkova1
1 28.08.2019 04:50
7
Ответы
petroura2
06.10.2020 00:00
#include <iostream>
#include <map>
#include <string>
using namespace std;
int main()
{
string mon;
map<string, int> months = {
{"январь", 1},
{"февраль", 2},
{"март", 3},
{"апрель", 4},
{"май", 5},
{"июнь", 6},
{"июль", 7},
{"август", 8},
{"сентябрь", 9},
{"октябрь", 10},
{"ноябрь", 11},
{"декабрь", 12}
};
cout << "Введите название месяца строчными буквами: ";
cin >> mon;
switch (months[mon]) {
case 2:
cout << "28 дней";
break;
case 1:
case 3:
case 5:
case 7:
case 8:
case 10:
case 12:
cout << "31 день";
break;
case 4:
case 6:
case 9:
case 11:
cout << "30 дней";
break;
}
cout << endl;
return 0;
}
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
алекей4
01.10.2019 19:20
Для записи текста использовался 256-символьный алфавит. каждая страница содержит 43 строк по 290 символов в строке. какой объем информации в байтах и кбайтах содержит 25 страниц...
aaalex02
01.10.2019 18:08
1. проведите анализ работы составных частей компьютера. 2.что является главной идеей темы? доказательства(обмен мнениями)...
adamchik
01.10.2019 18:08
40 , кратко ответьте на вопросы по информатике! ...
stesin761
20.04.2020 16:22
Подчеркните названия устроиств, которыми должен быть укомпликтован компьютер для работы с мультимидийными продуктами.названия на фотке...
grenki476
20.04.2020 16:21
1-4 фотографии образец. 5 фотография - сделать. (записать условие задачи и составленную программу)...
alenalapshna2
20.04.2020 16:21
1.Что такое Компас?(программа) 2.Почему программа Компас получила широкое рас Когда вышла в свет первая версия программы? 4.Назовите и охарактеризуйте основные продукты семейства...
alicahirdeeva
21.03.2021 15:24
1) Даны два целых числа. Программа должна вывести единицу, если первое число больше второго, двойку, если второе больше первого, или ноль, если они равны. Формат входных данныхВводятся...
ruslan426
21.03.2021 15:27
Створити вікно та багаторядкове поле. На виході матимемо 4 однорядкові таблиці з показниками температури за певний сезон. Python...
GameNooB
21.03.2021 15:28
сколько памяти в байтах занимает изображение размером 4 дюйма*5дюймов если разрешение изображения 200*200dpi а каждый пиксель кодируется тремя битами...
olyaolya22
21.09.2019 09:50
Сделать блок схему следующее: вычислить сумму отрицательных значений cos(fi) на интервале [а, b] с заданным шагом. (оператор цикла с предусловием)...
Популярные вопросы
Представьте обыкновенные дроби в виде бесконечных периодическую десятую дробь...
3
Перепишите, раскрывая скобки (Не)высокое дерево, далеко (не)удачный ответ,...
2
Установите правильное соответствие...
3
Я решаю и не понемаю чего это загадка...
1
Что ответить ЛП на такую историю??? Знаю что не школьный вопрос, но я просто...
1
1. Используя основное свойство дроби, найдите значение х чтобы равенство было...
1
Найти значение производной в точке х0в) f(x) = (3x^2+1) (3x^2-2), х0 =1...
2
Упрости выражение.3х-- 11 + 8 }- .10T147.912...
2
Он дома Ји, а коробка с клеем - 10 000 сум?есливика зубной пасты равна 11...
2
Выполните действия7-(2 3/4 +7/12) если что 2 это целое СОР...
3
#include <map>
#include <string>
using namespace std;
int main()
{
string mon;
map<string, int> months = {
{"январь", 1},
{"февраль", 2},
{"март", 3},
{"апрель", 4},
{"май", 5},
{"июнь", 6},
{"июль", 7},
{"август", 8},
{"сентябрь", 9},
{"октябрь", 10},
{"ноябрь", 11},
{"декабрь", 12}
};
cout << "Введите название месяца строчными буквами: ";
cin >> mon;
switch (months[mon]) {
case 2:
cout << "28 дней";
break;
case 1:
case 3:
case 5:
case 7:
case 8:
case 10:
case 12:
cout << "31 день";
break;
case 4:
case 6:
case 9:
case 11:
cout << "30 дней";
break;
}
cout << endl;
return 0;
}