с информатикой,нужно написать программу в Паскале. «В одномерном массиве A из n элементов найти максимальный среди всех элементов и заменить нулевые элементы на 30.»

maksategemberdi maksategemberdi    1   18.12.2021 10:03    1

Ответы
Vadim200129 Vadim200129  18.12.2021 10:10

const n = 20;

var i, max :integer;

   A: array[1..n] of integer;

begin

 max := 0;

 write('Массив A: ');

 for i := 1 to n do

 begin

   A[i] := random(0, 10);

   write(A[i], ' ');

   if A[i] > max then max := A[i];

 end;

 writeln();

 writeln('Максимальный элемент: ', max);

 write('Массив с заменами: ');

 for i := 1 to n do

 begin

   if A[i] = 0 then A[i] := 30;

   write(A[i], ' ');

 end;

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика