tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
С++ динамический массив
С++ динамический массив n x m. найти сумму элементов в каждом столбце
arino4ka3210
3 12.09.2019 13:30
3
Ответы
Gdyxtk
07.10.2020 09:44
/*VS C++*/
#include <iostream>
#include <ctime>
#include <iomanip>
using namespace std;
int main() {
int N, M, sum;
cout << "Vvedite N = "; cin >> N;
cout << "Vvedite M = "; cin >> M;
int **Arr = new int* [N];
for (int i = 0; i < N; i++)
Arr[i] = new int [M];
srand(time(0));
for (int i = 0; i < N; i++)
for (int j = 0; j < M; j++)
Arr[i][j] = rand() % 51;
for (int i = 0; i < N; i++)
{
for (int j = 0; j < M; j++)
cout << setw(4) << setprecision(2) << Arr[i][j] << " ";
cout << endl;
}
cout << endl;
for (int j = 0; j < M; j++)
{
sum = 0;
for (int i = 0; i < N; i++)
sum = sum + Arr[i][j];
cout << setw(4) << setprecision(2) << sum << " ";
}
cout << endl;
system("pause");
return 0;
}
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
popovapp26
23.10.2020 08:31
Информатика сор я српзу если...
Ээн
23.10.2020 08:31
4. Переведи число из двоичной системы в десятичную систему счисления. Распиши действия решения. [1] 1112...
arinaaaaaaaaa0
23.10.2020 08:31
Запиши мантиссу числа и порядок числа 2120000=0,212⋅107....
polina030502
23.10.2020 08:31
Задание 1. Тестирование готовой линейной программы. 1. Запустите программу Раsса1 ABC. 2. Откройте готовую программу, для этого выполните команды: Файл-Открыть в предложенном...
hocoladka
11.08.2019 17:50
Написать программу которая задает массив случайным образом и ищет минимальный элемент...
123вшагао
02.12.2020 16:08
Вычислить: (1v0)^(0^1)v(1v0)...
wowanuch72
02.12.2020 16:09
Соедини все буквы в одну цепочку так, чтобы оба эти утверждения были истинными: В этой цепочке предыдущая буква перед каждой — буква R. В этой цепочке четвёртая буква...
мират3
02.12.2020 16:09
Опять никто не Запишите число, которое будет напечатано в результате выполнения следующей программы. алгнач цел n, s s := 0 n := 0 нц пока s 25 s := s + 6 n := n +...
Юлдуз1122
02.12.2020 16:09
решите задачу по информатике...
kristinaaaaak
02.12.2020 16:09
Здравствуйте Как можно создавать модели в программе SketchUp? 2) Каковы функции инструментов управления пространством в программе SketchUp? 3) Для выполнения каких...
Популярные вопросы
Бала серіппелі тапаншадан вертикаль жоғары снарядты атқанда , қатаңдығы...
3
Какая форма (область)культура может быть проиллюстрирована с данной...
2
Табыс септік 1. Берілген сөздерге барыс септігінің жалғауын қосып...
3
Задания №1. Найдите среднее арифметическое ,размах, моду и медиана...
1
Физика тжб комектесиниздершии суркетте кокенистер тиелген кол арба...
1
Як канадці назвали(за твором П.Глазового Заморські гості ) українську...
3
Определи верность утверждений. 1. Национальный музей Республики...
3
Можете сделать 2- 5 задание заранее ....
1
, очень ! Роман «Тихий Дон», М.А. Шолохов. Вопрос: Как вы думаете,...
3
Найти расстояние между точками A(-30,80) и B(50,20). В правильной...
1
#include <iostream>
#include <ctime>
#include <iomanip>
using namespace std;
int main() {
int N, M, sum;
cout << "Vvedite N = "; cin >> N;
cout << "Vvedite M = "; cin >> M;
int **Arr = new int* [N];
for (int i = 0; i < N; i++)
Arr[i] = new int [M];
srand(time(0));
for (int i = 0; i < N; i++)
for (int j = 0; j < M; j++)
Arr[i][j] = rand() % 51;
for (int i = 0; i < N; i++)
{
for (int j = 0; j < M; j++)
cout << setw(4) << setprecision(2) << Arr[i][j] << " ";
cout << endl;
}
cout << endl;
for (int j = 0; j < M; j++)
{
sum = 0;
for (int i = 0; i < N; i++)
sum = sum + Arr[i][j];
cout << setw(4) << setprecision(2) << sum << " ";
}
cout << endl;
system("pause");
return 0;
}