tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Написать программу которая
Написать программу которая задает массив случайным образом и ищет минимальный элемент
hocoladka
1 11.08.2019 17:50
3
Ответы
FlexxZ000
04.10.2020 11:58
Const n=10;
var a:array[1..n] of integer;
min,i:integer;
begin
Randomize;
for i:=1 to n do begin
a[i]:=random(51);
write(a[i],' ');
end;
writeln;
min:=a[1];
for i:=2 to n do
if a[i]<min then min:=a[i];
writeln('min = ',min);
end.
Пример:
26 23 27 25 35 8 40 17 43 23
min = 8
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
ааа513
05.03.2021 11:36
две машины одновременно ходили из одного города в другой. поскольку скорость первой машины была на 20 км / ч выше, чем второй, первая машина прибыла на 15 минут раньше. если...
Alina243jhj
05.03.2021 11:36
Что будет в результате выполнения следующего алгоритма: Вводимое значение для переменной x= 5 x=int(input()) if x 0: print(x) else: print(x*x)...
tanyat2003
05.03.2021 11:37
Очень надо, сделайте через Python...
madinaseidahmet
05.03.2021 11:37
Float Str IntВосy= Information ООООb=FalseООх=981ОООa=25.86ОО сейчас сор...
marina9926
05.03.2021 11:37
В линейной программе поиска длины окружности с данным радиусом,впиши пропущенную функцию pi-3.14r-int(inpu( Задайте значение радиусу окружности= ))I=2*pi*r__?__(I) я ...
temamojet1997
05.03.2021 11:38
Какие существуют типы переменных:...
Ekaterina152005
05.03.2021 11:38
Как называется один из режимов Windows, позволяющий переключается в режим энергосбережения, сохраняя при этом рабочие файлы и программы на жесткий диск и позволяя безопасно...
Deloroza
14.04.2020 23:03
Составьте программу которая вычисли наименьшее из 20 чисел!...
kurroro
14.04.2020 23:03
Написать программу, которая увеличивает на 3 число, вводимое с клавиатуры, если оно больше 0, в противном случае уменьшает это число на 2. Программу написать в тетрадь...
орпасм
14.04.2020 23:04
Выберите числа, запись которых возможна в указанных системах счисления. Выделите цветом. 1012, 1000, 101, 512 в двоичной системе счисления 201, 312, 340, 100 в троичной системе...
Популярные вопросы
Отметьте на числовом луче с единичными отрезком 1 см точки б(3), н(7), д(11)...
1
Скласти письмову розповыдь про те,як ти мамі по малюнку ст 84 впр 203...
3
Чим тобі подобаеться осінь? текст міркування 5-7 речень....
2
Произведение чисел 28 и 5 уменьши на их сумму...
2
Один из смежных углов в 8 раз меньше другого.найдите больший из них....
3
Кконцам рычага, находящегося в равновесии, подвешены грузы 0,6 кг и 2,4...
1
в словосочетание горячийхлеб...
3
Вправельном треугольнике со стороной 4 см вписанна окружность и окружность...
3
Опишите меня с двенадцати ! кто первый напишет поставлю лучшее решение...
2
Выпишите числа, заключенные между числами 3 и 5...
1
var a:array[1..n] of integer;
min,i:integer;
begin
Randomize;
for i:=1 to n do begin
a[i]:=random(51);
write(a[i],' ');
end;
writeln;
min:=a[1];
for i:=2 to n do
if a[i]<min then min:=a[i];
writeln('min = ',min);
end.
Пример:
26 23 27 25 35 8 40 17 43 23
min = 8