Решите в python Пользователь вводит n чисел. Найти среднее арифметическое всех введённых чисел.
Ипполит задумал трёхзначное число, которое при делении на 15 даёт в остатке 11, а при делении на 11 даёт в остатке 9. Напишите программу, которая находит все такие числа.
Пользователь вводит с клавиатуры n чисел. Найти:

Произведение чётных чисел из последовательности;

Сумму нечётных чисел;

Количество положительных чисел

qoqo5 qoqo5    3   12.12.2020 15:14    13

Ответы
mashaaa98 mashaaa98  11.01.2021 15:14
1.

n = int(input("Введите сколько чисел вы хотите ввести: "))

a = []

for x in range(1, n + 1):

   a.append(int(input("Введите число " + str(x) + ": ")))

s = 0

for x in range(0, len(a)):

   s += a[x]

print("Среднее арифметическое всех чисел:", s/len(a))

2.

print("Числа, которые задумал Ипполит: ")

for x in range(100, 1000):

   if x % 15 == 11 and x % 11 == 9:

       print(x)

3.

n = int(input("Введите сколько чисел вы хотите ввести: "))

a = []

for x in range(1, n + 1):

  a.append(int(input("Введите число " + str(x) + ": ")))

c = []

n = []

p = 0

for x in range(0, len(a)):

   if a[x] % 2 == 0:

       c.append(a[x])

   elif a[x] % 2 != 0:

       n.append(a[x])

   if a[x] > 0:

       p += 1

u = 1

s = 0

for x in range(0, len(c)):

   u *= a[x]

for x in range(0, len(n)):

   s += a[x]

print("Произведение четных чисел:", u)

print("Сумма нечетных чисел:", s)

print("Количество положительных чисел:", p)

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика