tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Решите , используя язык
Решите , используя язык программирования паскаль: напишите программу вычисления стоимости покупки, состоящей из нескольких карандашей, линеек и тетрадей. их количество и цену задать вводом. ответ вывести в виде: сумма к оплате: … руб … коп.
lerabregneva
2 13.07.2019 04:00
8
Ответы
vershinindaniil1
03.10.2020 02:35
Var
k,kc,ks, r,rc,rs, l,lc,ls: Integer;
Summa: Integer;
begin
WriteLn('Введите цену карандаша'); ReadLn(kc);
WriteLn('Введите цену ручки'); ReadLn(rc);
WriteLn('Введите цену линейки'); ReadLn(lc);
WriteLn('Введите кол-во карандашей'); ReadLn(k);
WriteLn('Введите кол-во ручек'); ReadLn(r);
WriteLn('Введите кол-во линеек'); ReadLn(l);
ks:= k * kc; // цена карандашей
rs:= r * rc; // цена ручек
ls:= l * lc; // цена линеек
Summa:= ks + rs +ls; // общая цена всех 3-х
WriteLn('Сумма = ', Summa;
ReadLn;
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
Lngtnk5
12.09.2021 00:53
ОТ за верный ответ. скласти алгоритм визначення подільності націло на 3 і на 9 (составить алгоритм определения делимости нацело на 3 и на 9)...
поварешка1
11.06.2019 14:00
1. скорость передачи данных через wap-соединение равна 64 кбит/с. через данное соединение файл размером 18 мбит. определите время передачи файла в секундах. 2. текст, созданный с...
Ника85527
27.04.2021 00:32
Написать программу, определяющую в какой четверти координатной плоскости лежит точка используя сложное условие и связку and. Запись цикла While учить, работу доделать и сдат...
vlabiclavakozlova
27.04.2021 00:29
1. Определите длину кратчайшего пути между пунктами A и G. Передвигаться можно только по указанным дорогам. Между населенными пунктами A,B,C,D,E,F,G построены дороги, протяженность...
juliazxcvb
27.04.2021 00:23
Цветное изображение было оцифровано и сохранено в виде файла без использования сжатия данных. Размер полученного файла – 54 Мбайт. Затем то же изображение было оцифровано повторно...
amina340
14.03.2021 19:52
Определите режим работы гироскопического датчика с камандным блокам кто первый я его потпишусь:) ...
Nika1337228
13.09.2021 06:11
Кто напишет ответы к этому заданию, тот молодец и вы просто хороший человек....
Tigrica2017
13.09.2021 06:11
. 3. Прочитай твердження. Визнач, яке / які з них є правильним правильними Серед тваринних тканин є такі, що перебувають у рідкому стані. Міжклітинна речовина майже відсутня в епітеліальних...
малина106
13.09.2021 06:12
Какие риски преследуют пищевые производства...
SAVITAR75657
13.09.2021 06:12
Длина прямоугольника14 см,Что на 5 см больше его ширины . Найдите площадь Прямоугольника...
Популярные вопросы
Сколько надо воды жира и сахара на 2кг воды...
1
Вельможа привёз емеле 2 мешка пряников, всего 86 кг . в одном мешке было на 14...
3
Почему лимфатические узлы нелья масировать...
2
Найди лишнее слово: постройка, интересный, лестница, мансарда...
1
Ав десятой степени умножить на а в петнадцатой степени...
2
3кл быкова в конце р т как написать im my lunch box...
3
Вкоробке дежало 20 карандашей.10 карандашей стас заточил.сколько карандашей осталось...
1
Какое из чисел больше: 3+√8 или √7+√10 и почему. вроде, если 3 перевести в корень,...
2
Составьте таблицу ,,основные вехи китая...
1
Преобразуйте выражение в многочлен: x^2 + (5x-3)^2...
2
k,kc,ks, r,rc,rs, l,lc,ls: Integer;
Summa: Integer;
begin
WriteLn('Введите цену карандаша'); ReadLn(kc);
WriteLn('Введите цену ручки'); ReadLn(rc);
WriteLn('Введите цену линейки'); ReadLn(lc);
WriteLn('Введите кол-во карандашей'); ReadLn(k);
WriteLn('Введите кол-во ручек'); ReadLn(r);
WriteLn('Введите кол-во линеек'); ReadLn(l);
ks:= k * kc; // цена карандашей
rs:= r * rc; // цена ручек
ls:= l * lc; // цена линеек
Summa:= ks + rs +ls; // общая цена всех 3-х
WriteLn('Сумма = ', Summa;
ReadLn;
end.