решить задачу на питоне. Нужно через массивы. Числа Фибоначчи
F1 = F2 = 1, Fn = Fn-1 + Fn-2, при n > 2
Входные данные
В единственной строке входных данных записано натуральное число n (1≤n≤45).

Выходные данные
Вывести одно число Fn

Виталина5413 Виталина5413    2   08.11.2021 11:58    11

Ответы
www152 www152  08.12.2021 11:58

Відповідь:

Очень хороший код

def fibonacci_of(n):

   # Validate the value of n

   if not (isinstance(n, int) and n >= 0):

       raise ValueError(f'Positive integer number expected, got "{n}"')

   previous, fib_number = 0, 1

   for _ in range(2, n + 1):

       # Compute the next Fibonacci number, remember the previous one

       previous, fib_number = fib_number, previous + fib_number

   return fib_number

print(fibonacci_of(int(input(

Пояснення:

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика