Решить в паскале. с клавиатуры вводится время суток в часах (от 1 до 24). необходимо составить программу, которая будет выводить на экран согласно введенному времени. ввод: 1 вывод: доброй ночи

nnnnn777 nnnnn777    1   16.06.2019 14:40    12

Ответы
cako2004 cako2004  13.07.2020 10:31
Program myp;
var a:integer;
begin
readln(a);
if a = 1 then writeln('Доброй ночи');
end.
ПОКАЗАТЬ ОТВЕТЫ
Ксюша111111111111113 Ксюша111111111111113  13.07.2020 10:31
Var
  time : Integer;  begin
  writeln('Введите, который час: ');
    readln(time);
    if (time > 23) or (time < 0) then
   writeln('Так не бывает!')  else
    begin
      if ( time >= 0 ) and ( time < 6 ) then writeln('Доброй ночи!');
    if ( time >= 6 ) and ( time < 12 ) then writeln('Доброе утро!');
    if ( time >= 12 ) and ( time < 18 ) then writeln('Добрый день!');
    if ( time >= 18 ) and ( time < 24 ) then writeln('Добрый вечер!');
  end;  
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика