Решить в Напишите программу, которая вводит натуральное число N и выводит на экран все нату-ральные числа, не превосходящие N и делящиеся на каждую из своих цифр

cvetaharlanova cvetaharlanova    3   24.05.2021 09:54    3

Ответы
Артем14698752269 Артем14698752269  23.06.2021 09:57

n = int(input())

for i in range(1, n):

   flag = True

   for k in str(i):

       try:

           if i % int(k) != 0:

               flag = False

       except:

           flag = False

   if flag == True:

       print(i)

возможно можно проще))

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика