Решить на языке python 3.! последовательность состоит из натуральных чисел и завершается числом 0. определите, сколько элементов этой последовательности больше предыдущего элемента. (решение должно быть с циклом while)

Marinr Marinr    2   22.08.2019 19:50    16

Ответы
01029283736463637 01029283736463637  05.10.2020 13:16
# coding: utf-8

'''
Последовательность состоит
из натуральных чисел и завершается
числом 0. Определите, сколько
элементов этой последовательности
больше предыдущего элемента.

Python 3.X.
'''

prev = int(input()) # ввод первого элемента
count = 0 # изначально 0 элементов

while True:
    n = int(input()) # ввод числа
    if n == 0:
        break # выход, если 0
    if n > prev:
        count += 1
    prev = n # смещение числа

print(count, "эл.")
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика