Решить на python часть списка в конец имеется список из n элементов (n < 101). измените исходный список, переставив s элементов списка в конец, начиная с элемента под номером p. формат входных данных в первой строке вводится n (n < 101) - размерность списка. во второй строке через пробел вводятся n элементов списка в третьей строке вводятся числа s (количество переставляемых элементов) и p (номер первого из s элементов). формат выходных данных вывести измененный список. примеры входные данные 10 98 37 59 93 60 94 14 19 -38 -76 5 3 выходные данные 98 37 19 -38 -76 59 93 60 94 14

НикитаКлючников НикитаКлючников    2   22.09.2019 03:20    49

Ответы
KozyrevaAlbina KozyrevaAlbina  08.10.2020 08:34
n = int(input('Введите кол-во чисел: '))
a = []
for k in range(n):
 m = int(input('Введите число:'))
 a.append(m)
s = int(input('Введите кол-во заменяемых элементов: '))
for j in range(s):
 s1 = int(input('Внимание: [0] это индекс первого элемента. Введите индекс заменяемого элемента: '))
 a.append(a[s1])
 a.remove([s1])
print(a)
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика