Решить на паскале на компьютере: найти сумму нечетных положительных чисел из n введенных чисел. заранее ! (через for) program z1; var i,a: real; s,n: integer; writeln('введите кол-во чисел'); readln(n); s: =0; for i: =1 to n do begin; readln(a); if a mod 2 < > 0 and a> 0 then begin s: =s+a end; end; writeln (s); end. начала решать, не

Сенсей14 Сенсей14    2   17.06.2019 07:40    4

Ответы
Radigon Radigon  02.10.2020 03:21
var a,s,mn:real;     n,i:integer; begin clrscr; repeat write('Сколько чисел ввести n>0 n='); readln(n); until n>0; writeln('Введите ',n,' чисел:'); s:=0; for i:=1 to n do  begin   write('a=');   readln(a);   if i=1 then mn:=a   else if odd(i)and(a<mn) then mn:=a;   if(i mod 2=0)and(a>0) then s:=s+a;  end; writeln('Сумма положительных с четными индексами=',s:0:2); writeln('Минимальный с нечетным индексом=',mn:0:2); readln end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика