Решить хотя бы несколько из них . написать программу (c++) : а) вывести на экран первые n чисел ряда фибоначчи. б) найти нод n заданных с клавиатуры чисел. в) найти нок трех заданных чисел. г) задан прямоугольник с длинами сторон, выраженными целыми числами. из минимального количества квадратов его можно составить?

aantonenko240 aantonenko240    1   07.09.2019 22:30    3

Ответы
урган1 урган1  06.10.2020 23:45
А) Решение не совсем эффективно, но для школьного примера, то что нужно.
#include <iostream>
using namespace std;

unsigned fib(unsigned x)
{
    if (x == 0)
        return 0;
    if (x == 1 || x == 2)
        return 1;
    else if(x > 2)
        return fib(x - 1) + fib(x - 2);
}

int main()
{
    unsigned n = 0;
    cout << "How much numbers you want to print: " << endl;
    cin >> n;
    cout << "The Finonacci serie: " << endl;
    for(unsigned i = 0; i < n; ++i) {
      cout << fib(i) << " ";
    }
    return 0;
}
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика