Решить двумя напишите программу, которая получает с клавиатуры натуральное число и определяет, сколько раз в его десятичной записи встречается цифра 1. пример: введите число? 311 единиц: 2

Удача575 Удача575    2   23.08.2019 12:30    27

Ответы
ангел709 ангел709  05.10.2020 14:38
Program n1;
var num,k: integer;
begin
write('Введите число ');
readln(num);
k:=0;
while num<>0 do
begin
if abs(num mod 10)=1 then
k:=k+1;
num:=num div 10;
end;
writeln('Единиц: ',k);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика