Решить, 1) составьте программу которая заполняет массив a[1..10] случайными целыми числами в диапазоне от 1 до 10 и находит минимальный элемент массива среди элементов с нечетными индексами. 2) составьте программу которая заполняет массив a[1..10] случайными целыми числами в диапазоне от 1 до 10 и находит максимальный элемент массива, а затем вычисляет, сколько раз он встречается а массиве.

fhjanvmendwr fhjanvmendwr    1   13.08.2019 16:50    2

Ответы
Åпéłьčüñkå Åпéłьčüñkå  04.10.2020 16:26
1 задача:

const n=10;
var 
  min,i: integer;
  a: array[1..n] of integer;
begin
  randomize;
  min:=11;
  for i:=1 to n do begin
    a[i]:=random(1,10);
    write (a[i],' '); // для наглядности. можно удалить
    if  (i mod 2 =1) and (a[i]<min) 
      then min:=a[i];    
  end;
  writeln;
  writeln ('min = ',min)
end.

Пример:
5 4 7 8 6 2 10 4 9 9 
min = 5


2 задача:

const n=10;
var 
  max,count,i: integer;
  a: array[1..n] of integer;
begin
  randomize;
  max:=0;
  count:=0;
  for i:=1 to n do begin
    a[i]:=random(1,10);
    write (a[i],' '); // для наглядности. можно удалить
    if a[i]>max
      then max:=a[i];     
  end;
  for i:=1 to n do 
    if max=a[i] then count:=count+1;
  writeln;
  writeln ('max = ',max);
  writeln ('count = ',count);
end.

Пример:
8 5 3 2 2 10 10 9 3 10 
max = 10
count = 3
ПОКАЗАТЬ ОТВЕТЫ
Desa11 Desa11  04.10.2020 16:26
Program massiv;vara: array[1..10] of byte;min,i,k,n: byte;beginfor i:=1 to 10 do begin         a[i]:=random(10);         writeln(a[i]);         end;min:=a[1];k:=1;for i:=1 to 9 do    i:=i+2;    if a[i]<min then begin    min:=a[i];    k:=i;    end;writeln('min=',min, ' N ',k);end.

Решить, 1) составьте программу которая заполняет массив a[1..10] случайными целыми числами в диапазо
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика