Решить 1)дан массив из 20 элементов заполненный случайными целыми числами из интервала[-10; 10].выведите этот массив в строку и найдите наибольший элемент среди отрицательных элементов массива. 2)заполнить массив из 15 элементов заполненный случайными целыми числами из интервала от-10 до 10 вывести в строчку ,и повторно вывести в строчку заменив элементы не больше 3 их кубами pascalabc.net

linalimeofficip01ef8 linalimeofficip01ef8    1   25.07.2019 06:50    5

Ответы
zadyriakaartem zadyriakaartem  24.09.2020 11:17
1)
const n=20; 
var
  a:array[1..n] of integer;
  i,j,max:integer;
begin
Randomize;
Writeln('Исходный массив:');
for i:=1 to n do begin
  a[i]:=Random(21)-10;
  Write(a[i]:4)
end;
Writeln;
max:=-10;
for i:=1 to n do
 if (a[i]<0)and(a[i]>max) then max:=a[i];
Writeln('max = ',max);
end.

Пример:
Исходный массив:
  10  -8  10  -9   6   7   6   0  -4  10  -3   9   2  10   5   1   8  10   5   4
max = -3

2)
const n=15; 
var
  a:array[1..n] of integer;
  i,j:integer;
begin
Randomize;
Writeln('Исходный массив:');
for i:=1 to n do begin
  a[i]:=Random(21)-10;
  Write(a[i]:6)
end;
Writeln;
for i:=1 to n do
 if a[i]<=3 then a[i]:=a[i]*a[i]*a[i];
Writeln('Измененный массив:');
for i:=1 to n do Write(a[i]:6);
Writeln;
end.

Пример:
Исходный массив:
    -1    -4     9    -2    10    -9     6    -6     5    -1    -2     3     1    -8    10
Измененный массив:
    -1   -64     9    -8    10  -729     6  -216     5    -1    -8    27     1  -512    10
ПОКАЗАТЬ ОТВЕТЫ
StalinReal StalinReal  24.09.2020 11:17
// PascalABC.NET 3.1, сборка 1214 от 09.04.2016
begin
  var a:=ArrRandom(20,-10,10); a.Println;
  Writeln('Наибольший отрицательный элемент ',
    a.Where(x->x<0).Max)
end.

Тестовое решение:
8 -10 -6 -10 6 10 0 4 -6 -7 10 -2 -7 -10 3 -5 0 -9 3 3
Наибольший отрицательный элемент -2

// PascalABC.NET 3.1, сборка 1214 от 09.04.2016
begin
  var a:=ArrRandom(15,-10,10); a.Println;
  a.Select(x->x<=3?x*x*x:x).Println
end.

Тестовое решение:
7 -3 5 -5 4 7 2 1 -10 9 -2 -7 4 0 5
7 -27 5 -125 4 7 8 1 -1000 9 -8 -343 4 0 5
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика