Рассмотрим линейный массив целых чисел k [1..50]. напишите программу на языке pascal, используя процедуру, которая отображает положительные элементы на экране.

камаз9 камаз9    2   31.10.2019 22:14    3

Ответы
sadko77777 sadko77777  10.10.2020 10:51

const

 k = 10;

type

 tK = array[1..k] of integer;

var

 i: byte;

 a: tK;

procedure PrintPos(a: tK);

var

 i: byte;

begin

 for i := 1 to k do

   if a[i] > 0 then write(a[i], ' ');

 writeln;

end;

begin

 for i := 1 to k do

   Read(a[i]);

 PrintPos(a);

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика