Работа с паскалем. достаточно . даны 3 стороны a, b, c. написать программу, с которой будет выведено на экран тип треугольника (треугольник нельзя построить, равнобедренный, равносторонний, прямоугольный или разносторонний)

VeronikaKit VeronikaKit    1   17.07.2019 07:40    3

Ответы
alehalich alehalich  21.09.2020 16:42
Program pr;
uses crt; 
Var a,b,c:integer; 

Begin   
Write('Введите 1-ю сторону: '); Readln(a);   
Write('Введите 2-ю сторону: '); Readln(b);   
Write('Введите 3-ю сторону: '); Readln(c); 
  
{Проверка на существование треугольника} 
if ((a+b)>c) and ((a+c)>b) and ((b+c)>a)   then        
     Begin                     
          if ((a=b)or (b=c) or (a=c)) then               
                Writeln('Треугольник равнобедренный');                       
 
         if ((a=b) and (b=c)) then               
            Writeln('Треугольник равносторонний')                 
         else Writeln('Треугольник разносторонний');           
  
        if ((a*a+b*b = c*c) or (a*a+c*c = b*b) or (b*b+c*c = a*a))    then
             Writeln('Треугольник прямоугольный');                      
    end   
   else       Writeln('Треугольник нельзя построить');    

Readln(); 
END.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика