Python. напишите программу, которая переставляет соседние элементы массива: 1-й со 2-м, 3-й с 4-м и т.д. нумерация элементов начинается с единицы. входные данные первая строка содержит размер массива n . во второй строке через пробел n чисел – элементы массива. гарантируется, что 0 < n ≤ 10000 . выходные данные программа должна вывести в одну строчку все элементы получившегося массива, разделив их пробелами.

kdhsjs kdhsjs    1   14.09.2019 01:20    13

Ответы
ksenia6234 ksenia6234  04.08.2020 07:48
N = int(input())
a = input().split()
for i in range(0, n - n % 2, 2):
    a[i], a[i + 1] = a[i + 1], a[i]
print(' '.join(a))
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика