Python
Компьютер загадывает число. Напишите программу, которая его отгадывает

Артем00796678756 Артем00796678756    1   25.11.2021 07:26    80

Ответы
NcsON NcsON  25.11.2021 07:30

print("загадайте число!")

x = 0

y = 101

count = 0

print("50")

kod = input()

while kod != "=":

   if kod == "<":

       y = y - (y - x) // 2

       count = y - (y - x) // 2

   if kod == ">":

       x = x + (y - x) // 2

       count = x + (y - x) // 2

   print(count)

   kod = input()

Объяснение:

вы загадываете число

дальше программа вы водит предположительное число

если ваше число меньше этого то вы пишите "<", если больше то вы пишите ">", если программа у гадала ваше число то вы пишите " ="

ПОКАЗАТЬ ОТВЕТЫ
1232815 1232815  25.11.2021 07:30

Компьютер загадывает число. Напишите программу, которая его отгадывает. КОМПЬЮТЕР и должен это число отгадывать.

Объяснение:

from random import randint

n=randint(1,100)

print('Компьютер загадал число  ',n)

mn=1

mx=100

s=0

a=-1

while a!=n:

   a=randint(mn,mx)

   s+=1

   if a>n:

       print(a, ' число >')

       mx=a-1

   elif a<n:

       print(a, ' число <')

       mn=a+1

   else:

print(a, 'Угадали. Количество попыток=',s);


Python Компьютер загадывает число. Напишите программу, которая его отгадывает
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика