Python 3.7
напишите программу, которая вводит с клавиатуры числа до тех пор, пока не будет введено число 0. в конце работы программы на экран выводятся количество чисел (0 не считаем), минимальное и максимальное из введенных чисел, их сумму и среднее значение.
заранее большое

Matthieu5401 Matthieu5401    2   12.10.2019 14:52    4

Ответы
thebrianmaps2000 thebrianmaps2000  10.10.2020 06:09

{с клавиатуры вводится число a, до тех пор, пока не будет введен 0. Начальное введенное a записывается в min  и max, чтобы потом в цикле было с чем сравнивать}

var

min,max,a:real;

begin

  readln(a);

  min:=a;max:=a;

   while a<>0 do

       begin

            readln(a);

                if a>max then

                    max:=a;

                if a<min then

                     min:=a;

        end;

writeln('min: ',min,'  max: ',max);

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика