Python 1) Программа получает на вход количество чисел в последовательности (натуральное число), а затем сами числа (целые). Найдите произведение чисел последовательности не кратных 5

2) Программа получает на вход количество чисел в последовательности (натуральное число), а затем сами числа (целые). Найдите количество чисел последовательности оканчивающихся на четную цифру

3) Вводятся два натуральных числа а и с. На отрезке от 0 до а, найдите все числа, последняя цифра которых кратна с

Python

gorlatenkoviktoria gorlatenkoviktoria    2   24.10.2021 00:09    8

Ответы
Кирилл11111111111110 Кирилл11111111111110  24.10.2021 01:00

1)

# На вход: кол-во чисел, сами числа

# Выход: кол-во чисел не кратных 5

count:int = input('Кол-во чисел?: ')

ints = []

for i in range(int(count)):

   ints.append(input('Число ' + str(i+1) + ': '))

result = []

for i in ints:

   if int(i) % 5 != 0:

       result.append(i)

print(result)

2)

# На вход: кол-во чисел, сами числа

# Выход: кол-во чисел в конце которых чётное число

count:int = input('Кол-во чисел?: ')

ints = []

for i in range(int(count)):

   ints.append(input('Число ' + str(i+1) + ': '))

result = []

for i in ints:

   if int(i) % 2 == 0:

       result.append(i)

print(result)

3)

# На вход: числа A и C

# Выход: числа, последняя цыфра которых кратна С

A = input('Отрезок от 0 до ')

C = input('Найти числа, кратные ')

result = []

for i in range(0, int(A)):

   if i % int(C) == 0:

       result.append(i)

   

print(result)

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика