Программу надо написать на c++ Программу надо написать на c++ Программу надо написать на c++ Поменять местами
Дано натуральное четырехзначное число, необходимо поменять местами средние цифры.
Входные данные
Входные данные содержат единственное целое четырехзначное число.
Выходные данные
В ответ напишите четырехзначное число, которое получается из исходного обменом двух средних цифр.
Примечание
В этой задаче запрещено использовать символьный тип данных.
Программу написать надо на c++ Программу надо написать на c++ Программу надо написать на c++

тто тто    3   20.10.2020 00:49    7

Ответы
vikagevorgiz vikagevorgiz  19.11.2020 00:50

#include <cmath>

#include <iostream>

using namespace std;

int main(){

   int a,b,c,d;

   cin >> d;

   a = d%10;

   b = d%100/10;

   c = d/100%10;

   d /= 1000;

   d = d*1000+b*100+c*10+a;

   cout << d;

   return 0;

}

Объяснение:


Программу надо написать на c++ Программу надо написать на c++ Программу надо написать на c++ Поменят
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика