tutotveti.ru
Предметы
Биология
Физика
Українська мова
Музыка
Французский язык
Обществознание
МХК
Право
ОБЖ
Психология
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Русский язык
Английский язык
Окружающий мир
Алгебра
Другие предметы
История
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Программисты ! надо написать программу
Программисты ! надо написать программу на паскале, найти произведение отрицательных элементов массива.
ivanushka2
3 22.09.2019 13:40
4
Ответы
нипета
08.10.2020 09:40
Program n1;
var a: array[1..10] of integer;
i,p: integer;
begin
randomize;
write('массив: ');
p:=1;
for i:=1 to 10 do
begin
a[i]:=random(21)-10;
write(a[i],' ');
if a[i]<0 then p:=p*a[i];
end;
writeln;
write('произведение отрицательных: ',p)
end.
ПОКАЗАТЬ ОТВЕТЫ
sveta998
08.10.2020 09:40
PascalABC.NET 3.3.5, сборка 1650 от 01.04.2018
Внимание! Если программа не работает, обновите версию!
begin
var a:=ArrRandom(ReadInteger('n='),-50,50); a.Println;
a.Where(t->t<0).Aggregate(BigInteger(1),(p,q)->p*q).Println
end.
Пример
n= 15
-44 -33 -7 48 14 44 -14 -14 -45 -13 16 47 -48 19 -14
-783151649280
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
Martishevska
05.12.2020 11:48
Что такое - бит, байт, килобайт, мегабайт? Скажите ...
Nadezhda136
05.12.2020 11:46
информатика: 1. PowerPoint. Что такое презентация?2. PowerPoint. Сравните три показа слайдов на экране: управляемый докладчиком (полный экран, окно), автоматический, сфера и особенности...
petrius100p0bmz5
05.12.2020 11:46
Укажите правильный ответ: целостное отражение объекта непосредственно воздействующего на наши органы чувств-это варианты ответа:1.представление2.ощущение 3.восприятиеОчень нужно...
ЮляКіска
21.06.2021 10:54
Написать родительский класс Animal и двух наследников Fish, Bird Используя вектор из указателей на базовый класс прочитайте рыб и птиц из текстового файла animals.csv. Для классов...
10203040502017
21.06.2021 10:55
если можно, прикрепите сюда работу word, если нет - свяжитесь со мной через комментарии....
Аня230156
21.06.2021 11:24
Докажите выполнимость данной формулы ¬(((R ∧ Q) ∧ P) → (Q ∧ R))...
аллалесниченко
21.06.2021 11:31
Заполните двумерный числовой массив N[9,5] случайными целыми числами в интервале[-15; 9]. Выведите значения элементов массива в виде матрицы, причём на каждый элемент отведите 4 позиции....
popirina2001
21.06.2021 11:34
Как убрать пустую странице в вроде на телефоне??? ...
lera5471
21.06.2021 11:41
Ребят хелп что случилось с компом? Включил комп и тут вот такое...
ponchikelo
18.07.2019 11:20
Дайте определение оперативной памяти...
Популярные вопросы
Реакції взаємодії речовин з киснем, в результаті яких виділяється світло і тепло,-це...
1
У мами 2 яблука, 3 груші і 4 апельсини. Кожний день вона дає дочці по одному фрукту....
2
.Приведите примеры рудиментов и атавизмов человека. большая прозьба не списывать...
3
Переваги і недоліки електронних грошей...
2
Які події лягли в основу «Слова о полку Ігоревім». Яка головна думка твору?...
3
По требованиям органов государственного надзора проводится: a) внеплановый инструктаж...
1
При делении ядер урана 922 (верхнее число) 35 (нижнее) U освобождается энергия...
3
Что такое результат импликации...
3
До ть, будь ласка. При тиску 100 кПА і температурі 10 C певна маса повітря має...
1
Вантаж масою 25 кг рівномірно переміщають угору похилою плошиною під кутом 45°...
1
var a: array[1..10] of integer;
i,p: integer;
begin
randomize;
write('массив: ');
p:=1;
for i:=1 to 10 do
begin
a[i]:=random(21)-10;
write(a[i],' ');
if a[i]<0 then p:=p*a[i];
end;
writeln;
write('произведение отрицательных: ',p)
end.
Внимание! Если программа не работает, обновите версию!
begin
var a:=ArrRandom(ReadInteger('n='),-50,50); a.Println;
a.Where(t->t<0).Aggregate(BigInteger(1),(p,q)->p*q).Println
end.
Пример
n= 15
-44 -33 -7 48 14 44 -14 -14 -45 -13 16 47 -48 19 -14
-783151649280