Программирование на языке Puthon
Представь, что кадеты Марсакадемии играют в «лесенку»: первый подтянулся a раз. Второй на 1 раз больше. Первый снова на 1 раз больше, и так далее. В последний раз игрок сумел подтянуться b раз. Сколько всего подтягиваний было в игре?
Написать программу на языке puthon при цикла while. Можно использовать if, else, >=, <=, ==, !=. желательно с обьяснениями #

ecuzera2611 ecuzera2611    2   24.05.2020 19:53    12

Ответы
9763 9763  15.10.2020 07:46

b = int(input("До скольки подтягиваний дошли : "))

c = 0

i = 1

while b > i:

   i += 1

   c += i

print(c + 1)

Объяснение:

Да не самое компактное, но...

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика