tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Программирование на языке паскаль!
Программирование на языке паскаль! заполните массив степенями числа 2,так чтобы последний элемент массива был равен 1,а каждый предыдущий был в 2 раза больше следующего. пример 36 16 8 4 2 1
Sofa8412
3 09.09.2019 04:10
19
Ответы
79366
07.10.2020 02:18
Var a:array[1..20] of integer;
n,i:integer;
begin
readln(n);
a[n]:=1;
for i:=n-1 downto 1 do a[i]:=a[i+1]*2;
for i:=1 to n do write(a[i],' ');
end.
Пример:
15
16384 8192 4096 2048 1024 512 256 128 64 32 16 8 4 2 1
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
AnyaFashion
10.06.2020 17:48
вставь пропущенное слово. -это несколько элементов с общими именем и нумерацией....
Vitalikprofi
10.06.2020 17:43
отметьте верные утверждения. правильно ответов несколько. а.шаг алгоритма понятно исполнителю. б.алгоритм может быть бесконечно длинным. с.результат достижим за...
birgowww
09.06.2020 17:41
Паскаль : Создать файл - сводная экзаменационнная ведомость. Каждая строка ведомости состоит из фамилии студента и 3-х оценок. В новый файл переписать фамилии студентов,...
Kate27love
09.06.2020 17:24
Решить в питонеЧисла A и B (A...
zuldzbeysengaz
09.06.2020 17:22
Написать программу. Вычислить сумму наибольших элементов каждого столбца матрицы A(I*J), записанный в текстовый файл. Сформировать из них вектор С, и дописать его...
modernteenager1
09.06.2020 17:17
Задано дані у вигляді (маса; об єм) n предметiв, які виготовлені з різніх матеріалів. Скласти програму, яка визначає максимальну щільність матеріалу. Підказка: щільність...
samolutchenckova
09.06.2020 17:16
решить в питоне Положительное число дается в диапазоне 100–999. Создайте программу, которая производит описание словаря в соответствии с введенным номером: 256 -...
serega5152
09.06.2020 17:05
1. Каким будет содержание пары регистров с данными 0001 0000 0000 1111 после инкрементирования? 2. Каким будет содержимое регистра с данными 0100 1011 после декрементирования?...
Manya1316
09.06.2020 16:57
решить в питоне.Числа A и B (A...
nikita5000011111
09.06.2020 16:48
Задание 1. Освойте основные приемы работы в текстовом редакторе Word Порядок выполнения работы 1. Запустите программу Microsoft Word, пользуясь меню Пуск/Программы/Microsoft...
Популярные вопросы
:)( в трапеции авсд основание ад двое больше основания вс и вдовое...
3
1.смешавшиеся на полу мастерской железные и цинковые опилки потребовалось...
2
Вычислите массу caco3, полученного при взаимодействии 20 л co2,...
2
Сколько нечетных шестизначных чисел можно составить из цифр 1...
1
Из одной точки одновременно в разные стороны выехали два велосипедиста....
2
В2010 году денежная масса в украинской выросла по показателю...
2
Площадь прямоугольника равна 5,76м в квадрате а одна из его сторон...
2
Написати творчу роботу пісні мого місця...
1
Написать программу! 1. запишите следующие условия: числа a и...
1
Каковы правила пунктуации при обособлении определений и приложений?...
2
n,i:integer;
begin
readln(n);
a[n]:=1;
for i:=n-1 downto 1 do a[i]:=a[i+1]*2;
for i:=1 to n do write(a[i],' ');
end.
Пример:
15
16384 8192 4096 2048 1024 512 256 128 64 32 16 8 4 2 1