Программа умоляю , все плохо! напишите программу, которая заполняет квадратную матрицу случайными числами в интервале от 10 до 90 и находит максимальный и минимальный элементы в матрице.

Bklbgnk Bklbgnk    3   28.06.2019 06:40    4

Ответы
Dobro118 Dobro118  02.10.2020 13:42
{uses Crt;}
{Для древних сред Паскаль, работающих в DOS-режиме, снять комментарии
 в операторах uses, ClrScr, ReadKey }
const
  n = 10;
var
  a: array[1..n, 1..n] of integer;
  i, j, min, max: integer;
begin
  Randomize;
  {ClrScr;}
  Writeln('Исходный массив');
  max:=-100; min:=100;
  for i := 1 to n do
  begin
    for j := 1 to n do
    begin
      a[i, j] := Random(81)+10;
      Write(a[i,j]:3);
      if max<a[i,j] then max:=a[i,j]
      else
        if min>a[i,j] then min:=a[i,j]
    end;
    Writeln
  end;
  Writeln('min=',min:2,', max=',max:2);
  {ReadKey}
end.

Тестовое решение:
Исходный массив
 38 43 63 12 80 87 22 82 39 52
 88 82 79 35 68 67 66 63 84 85
 78 48 46 26 63 71 32 71 86 45
 11 38 55 12 75 85 68 13 64 88
 87 16 27 26 74 34 88 76 26 25
 74 45 17 18 43 81 88 46 40 18
 65 41 87 85 51 59 36 76 51 73
 90 63 89 87 88 71 31 29 43 38
 74 47 55 70 61 56 31 46 60 84
 88 31 64 56 32 55 19 32 66 24
min=11, max=90
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика