программа Python Составить программу для вычисления количества всех чётных двухзначных двузначных положительных чисел.

Katia1717 Katia1717    3   19.06.2020 02:11    6

Ответы
Kissss1111 Kissss1111  15.10.2020 14:26

В массив добавляются случайные числа в диапазоне от -150 до 150. Дальше код обрабатывает массив в соответствии с вашими требованиями (а именно: "вычисление количества всех чётных двузначных положительных чисел"). Прикрепил также скриншот с кодом и выводом компилятора:

import random

numbers = []

am = int(input("amount of numbers = "))

for i in range (am):

   numbers.append(random.randint(-150,150))

print(*numbers)

count = 0

for i in range (am):

   if ((numbers[i] % 2 == 0) and (numbers[i] > 0)):

       if (len(str(numbers[i])) == 2):

           count += 1

print ("amount of all even two-digit positive numbers = ", count)


программа Python Составить программу для вычисления количества всех чётных двухзначных двузначных по
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика