Программа на с++ напишите программу, которая находит номер максимального элемента массива. входные данные в первой строке задается одно натуральное число n, не превосходящее 1000 – размер массива. во второй строке вводится n чисел – элементы массива (целые числа, не превосходящие по модулю 1000). выходные данные вывести одно число – номер максимального элемента в массиве. если в массиве несколько максимальных элементов, выведите номер любого из них. примеры входные данные 5 5 4 3 2 1 выходные данные 1

nastiaandreeva nastiaandreeva    3   09.09.2019 03:50    4

Ответы
sashunyakotova sashunyakotova  07.10.2020 02:16
#include <iostream>

using namespace std;

int main() {
int n;
cin >> n;
 short *arr = new short[n];

for (int i = 0; i < n; i++) {
 cin >> arr[i];
}
int max = arr[0];
for (int i = 0; i < n; i++) {
  if (arr[i] > max) {
  max = arr[i];
 }
 }
 cout << max;
return 0;}
ПОКАЗАТЬ ОТВЕТЫ
shilinvanechka shilinvanechka  25.10.2020 10:10

#include <iostream>

#include  <math.h>

 

using std::cout;

using std::cin;

 

int main (){

int N,b,c,k;

cin >> N;

c = 0;

k = 0;

for (int i = 0; i != N ; i++){

   cin >> b;

   if(i==0)

    {

     c=b;

    }

else

 {

   if (c < b){

       c = b;

   }    

   }

   

}

cout << k;

 

return 0;

}

Объяснение:

ПОКАЗАТЬ ОТВЕТЫ
Alena26vl Alena26vl  25.10.2020 10:10
C#
int n = Convert.ToInt32(Console.ReadLine());
int max = 0;
int index = -1;
int [] mass = new int [n];
Random rnd = new Random();

for (int i = 0; i< mass.Length; i++)
{
mass[i] = rnd.Next();
Console.WriteLine(mass[i] + " ");
}

for (int i = 0; i < mass.Length; i++)
{
if (mass[i] > max)

max = mass[i];
index = i;
}
}
Console.WriteLine("Индекс наибольшего равен " + index);

короч просто описываю что надо:
1) Заводишь переменные для максимума и индекса
2) Заполняешь массив рандомными числами
3) выводишь массив
4) пробегаешь по массиву, сверяя элементы с максимумом
- если max меньше элемента, то присваиваешь ему элемент и запоминаешь в index номер элемента
5) выводишь индекс элемента

в коде все понятно будет, я думаю
но я думаю вам нужен паскаль, но на паскале я не могу с массивами, не люблю я их.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика