Программа, которая вычисляет сумму всех делителей заданного натурального числа n и находит все нечетные делители этой суммы. входные данные - в первой строке входного файла input.txt cсодержится число n(1< =n< =6*10^8) выходные данные -в выходной файл output,txt вывести все нечетные делители в порядке возрастания. пример - input.txt = 10, output.txt = 1 3 9

кошка372 кошка372    3   06.08.2019 03:40    1

Ответы
princessTonya princessTonya  04.10.2020 00:23
//PascalABC.NET 3.2 сборка 1318

Var
  f:text;
  n,sum,i:integer;
begin
assign(f,'Input.txt');
reset(f);
read(f,n);
close(f);
for i:=1 to n do
  if n mod i=0 then sum:=sum+i;
assign(f,'Output.txt');
rewrite(f);
for i:=1 to sum do
  if (sum mod i=0) and (odd(i)) then write(f,inttostr(i)+' ');
close(f);
end.

Пример содержимого Input.txt:
4
Пример содержимого Output.txt:
1 7
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика