Подскажите, , где ошибки и как корректно составить программу? (в pascal) само : удвоить все символы в строке.

fill1337 fill1337    2   05.05.2019 17:21    3

Ответы
Bredyatish Bredyatish  09.06.2020 11:31
Ошибка

В строке  's2:= s2 + s1[i] + s1[i];'

По умолчанию все переменные равны нулю

т.к. вы не задали значение i и вводите эту строку вне цикла for, то получается что вы запрашиваете нулевой элемент массива s1, при том что нумерация начинается с единицы, поэтому и выдаёт ошибку.

"Индекс находится вне границ массива"

Верный код программы

program raf105;

var s1,s2:string;

i:integer;

begin

writeln('Введите строку');

readln(s1);

s2:='';

for i:=1 to length(s1) do

 s2:= s2 + s1[i] + s1[i];

writeln(s2);

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика