По паскалю. 1. написать программу, которая вводит последовательность вещественных чисел, состоящую из n элементов, и определяет, является ли эта последовательность возрастающей. 2. дан целочисленный массив размерности n. необходимо "сжать" массив, выбросив из него каждый второй элемент. дополнительный массив использовать нельзя.

pro100skill132 pro100skill132    3   30.03.2019 15:40    3

Ответы
IrinaErmolenko IrinaErmolenko  27.05.2020 17:51

var a:array[1..1000]of longint;
n,i,kol:longint;
begin
read(n);
for i:=1 to n do
read(a[i]);
for i:=1 to n-1 do
if a[i]<a[i+1] then kol:=kol+1;
if kol=n then write('vorast') else writeln('net');
end.

 

 

var a:array[1..1000]of longint;
n,i:longint;
begin
read(n);
for i:=1 to n do
read(a[i]);
for i:=1 to n do
if i mod 2 <>0 then write(a[i],' ');
end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика