tutotveti.ru
Предметы
Биология
Физика
Українська мова
Музыка
Французский язык
Обществознание
МХК
Право
ОБЖ
Психология
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Русский язык
Английский язык
Окружающий мир
Алгебра
Другие предметы
История
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Перевод кода паскаль в c++
Перевод кода паскаль в c++ 1 var i,n: integer; p: real; begin writeln('введите n'); readln(n); p: =1; if odd(n) then begin for i: =1 to n do if odd(i) then p: =p*i end else for i: =1 to n do if not odd(i) then p: =p*i; writeln(p); end.
Анюта3Б
3 07.09.2019 14:00
2
Ответы
AzalieySagaz
06.10.2020 23:09
#include <iostream>using namespace std;
int main() { int i, n; unsigned p; cout << " N" << endl; cin >> n; p = 1; if (n&1) { p = p * i; } else { for (i=0; i<n; i++) { if (! i&1) { p = p*i; } } } cout << p << endl; return 0;}
Вроде как-то так. За правильность работу не ручаюсь, т.к. не знаю как работает программа на паскале. Надеюсь верно...
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
hudognik78
09.03.2021 19:08
Верно ли утверждение, что языки программирования высокого уровня ближе к человеческому пониманию и записывается в текстовом режиме? •верно•неверно 2. Определите...
СоняЗагребова5
11.06.2019 21:50
Каким видом редактора является ms paint? а) художественным в) аудио с) текстовым д) графическим какой пункт меню ms paint устанавливает размеры холста? а) масштаб...
морж14
11.06.2019 21:50
Составить блок систему таблицу умножения на 3...
uraalekseev1234
11.06.2019 21:50
Одна печатная страница содержит 30 строк по 70 символов в каждой. в алфавите 256 символов. какое количество информации несет текст, состоящий из 5 таких страниц?...
ерикос
11.06.2019 21:50
Написать программы! ) заполнить массив из 15 элементов случайным образом: 1. вещественными значениями x (22...
lolkek6969
06.06.2019 16:30
Какой результат вы получите после вычисления выражения 48 mod 20 =...
N4kes
06.06.2019 16:30
Надо. заранее большое ) 1) определите и выведите на экран количество четырехзначных чисел, которые делятся без остатка одновременно на 5 и 11. 2) найдите и выведите...
Sabinakerimli
06.06.2019 16:40
Проверьте, делится ли выбранное число на 5, на 11 или 13 нужно сделать в pascal abc...
redkiller22
06.06.2019 16:40
Реши анаграммы и скажи какое из этих животных самое маленькое пират лунка накал...
Radon86
06.06.2019 16:40
Написать программу, которая определяет значение целочисленной переменной a, после выполнения фрагмента алгоритма: a: =247; в: =(а*div 100) * 10-9 а: =(10*b-a) mod...
Популярные вопросы
До столового оцту масою 150 г з масовою часткою кислоты 9% додали...
1
Будь ласочка! насамперед дякуюю♡♡♡будь ласка будь ласочка! 1)у...
2
Реки города багдад ,будапешт,архангельск,калькутта, лондон,прага,киев,париж,варшава....
2
Сочинение на тему как я готовлюсь к экзаменам...
2
Из перечниз перечня формул выпишите отдельно формулы основных...
2
Представьте, что вы сидите на берегу моря (озера, реки, пруда).что...
3
По 7 класс название горной системы и название эпохи складчатости(европа...
1
Твір на тему: кого називають сміливцем 5-6 речень....
3
Вопрос на 100 ! если бы на 1 секунду исчезло солнце, что бы...
3
Решить неравенство 3х-2/4+4х+1/3 =0...
3
int main() { int i, n; unsigned p; cout << " N" << endl; cin >> n; p = 1; if (n&1) { p = p * i; } else { for (i=0; i<n; i++) { if (! i&1) { p = p*i; } } } cout << p << endl; return 0;}
Вроде как-то так. За правильность работу не ручаюсь, т.к. не знаю как работает программа на паскале. Надеюсь верно...